Tepjag
Messages : 49
Enregistré le : 01 juil. 2014, 17:32
Contact : Envoyer un message privé Site Internet

[résolu] Erreur sur montage partition

14 oct. 2014, 12:27

Bonjour à tous,
Suite à une manip probablement erronée, je ne peux plus monter une partition de données.
L'environnement :
Je suis sous dual-boot, un disque XP (sda), l'autre Xubuntu (sdb)
sda est partitionné avec sda2 pour le système XP et sda4 pour les données communes aux 2 OS. sda1 et 3 sont les utilitaires et restore.
Dans mes données communes, j'ai ma messagerie Thunderbird que je peux utiliser soit avec Xp (rarement) soit avec Xubuntu (cas normal).
Avant d'appeler Thunderbird, je dois donc monter la partition sda4 (appelée Hejmo) et je le faisais manuellemant.
Partisan du moindre effort, j'ai entrepris de faire monter automatiquement cette partition au démarrage d'où la manip propablement erronée.
Le problème :
J'ai utilisé le tutoriel : http://doc.ubuntu-fr.org/tutoriel/monte ... atiquement
J'ai bien pris les infos depuis mtab après avoir monté la partition et bien renseigné ensuite fstab (après le mkdir)
Malheureusement, si le démarrage ne pose pas de problème, la partition ne se monte pas et ça coince si j'essaie un montage manuel avec le message d'erreur :

Code : Tout sélectionner

Error mounting system-managed device /dev/sda4: Command-line `mount "/media/pierre/Hejmo"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda4,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
Le contenu de la fstab est :

Code : Tout sélectionner

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb6 during installation
UUID=3d6485ca-f2a6-40a6-9f6f-2e20416503f3 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sdb7 during installation
UUID=b9f0ba88-6468-48b8-bb66-3a16fecf0a38 /home           ext4    defaults        0       2
# swap was on /dev/sdb5 during installation
UUID=1110e1e4-d895-4dc3-a285-a9d20d492378 none            swap    sw              0       0
/dev/sda4 /media/pierre/Hejmo fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096,noauto 0 0
J'avoue être dépassé car je ne sais pas revenir en arrière, effacer cette ligne de fstab pour revenir au montage manuel.
Merci de vos conseils.
Cordialement
Pierre J.
Modifié en dernier par Tepjag le 15 oct. 2014, 22:47, modifié 1 fois.
Xubuntu 14.04 dual W-XP

pingux
Messages : 2460
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Erreur sur montage partition

14 oct. 2014, 18:19

Hello Tepjag, essaie de mettre la dernière ligne de fstab en commentaire pour cela tu mets un # au début de la ligne. Tu doit ouvrir fstab en root pour cela :

Code : Tout sélectionner

sudo mousepad /etc/fstab
Dura Lex sed Lex

Tepjag
Messages : 49
Enregistré le : 01 juil. 2014, 17:32
Contact : Envoyer un message privé Site Internet

Re: Erreur sur montage partition

14 oct. 2014, 19:54

Salut Pingux,

Merci de ta réponse. Ça marche !
Curieusement, j'ai peut-être trouvé l'origine du pb : En voulant relancer Tb, j'ai eu un message d'erreur du type "chemin du profil erroné" et effectivement dans le profiles.ini de .thunderbird j'ai comme chemin "/media/pierre/Hejmo/Thunderbird/..." alors que le point de montage de ma partition est "media/pierre/Hejmo1/".
D'où vient ce changement Hejmo en Hejmo1, je ne sais pas :?:
J'aimerai bien supprimer ce "1" inutile dans le nom du point de montage mais ne souhaite tout casser. As-tu des conseils à me donner.
J'essaierai de refaire la manip du tutorial pour automatiser ce montage :mrgreen:

Cordialement
Pierre J.
Xubuntu 14.04 dual W-XP

pingux
Messages : 2460
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Erreur sur montage partition

14 oct. 2014, 22:51

Tu peux supprimer ce "1" gênant mais auparavant tu fais une sauvegarde de sécurité de "profiles.ini" dans un terminal :

Code : Tout sélectionner

cd .thunderbird
cp profiles.ini profiles.ini.sav
Comme cela en cas de problème il te suffira de supprimer profiles.ini et de renommer profiles.ini.sav en profiles.ini.
Dura Lex sed Lex

Tepjag
Messages : 49
Enregistré le : 01 juil. 2014, 17:32
Contact : Envoyer un message privé Site Internet

Re: Erreur sur montage partition

15 oct. 2014, 22:45

Bonsoir Pingux,
Merci de ton aide.
Je ferai mes essais plus tard quand j'aurai moins de risques, pour l'instant, j'ai vraiment besoin de l'ordi en état de marche !
Je mets le pb résolu.
Amicalement
Pierre J.
Xubuntu 14.04 dual W-XP

pingux
Messages : 2460
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: [résolu] Erreur sur montage partition

16 oct. 2014, 09:16

Tu peux franchement faire la manip, c'est sans risque. Personnellement je fais régulièrement une copie de sauvegarde du dossier .thunderbird à l'aide du gestionnaire de fichiers au cas ou. Comme cela tous les paramètres du compte de messagerie sont sauvegardés, idem pour le dossier .mozilla (firefox). C'est pratique en cas de réinstallation.
Dura Lex sed Lex

Tepjag
Messages : 49
Enregistré le : 01 juil. 2014, 17:32
Contact : Envoyer un message privé Site Internet

Re: [résolu] Erreur sur montage partition

17 oct. 2014, 23:00

Bonsoir Pingux,
Merci de ton avis, je vais faire ça dès que possible.
Je sauvegarde régulièrement le dossier .thunderbird, en effet c'est plus sûr !
Cordialement.
Xubuntu 14.04 dual W-XP

Retourner vers « Xubuntu »