Cet espace permet de solliciter aide et conseils sur Xubuntu.
Bienvenue à tous !
bcaulier
 
Messages: 40
Inscription: 15 Mai 2016, 09:33

[Resolu] GRUB ne détecte pas windows 10 après l'installation

de bcaulier 29 Déc 2016, 17:19

Bonjour,
Sur portable MSI GP72 6QE Leopard pro avec Win10.
J'ai forcé l’arrêt complet de Windows pour éviter une mise en veille (hibernation de $W par défaut)
J'ai partitionné le disque pour recevoir Xubuntu.
J'ai installé Xubuntu16.04.1 en dual boot avec Windows 10 à partir d'une clé USB.
L'installation s'est bien passé et Xubuntu fonctionne correctement.
Sous Xubuntu je peux lire le contenu de la partition Windows.
Mais, au reboot, grub ne me propose pas Windows !!!
Sous Xubuntu, j'ai lancé :
Code: Tout sélectionner
sudo grub-install /dev/sda
Installation pour la plate-forme i386-pc
Installation terminée, sans erreur.

sudo os-prober
/dev/sda1:Windows 10 (loader):Windows:chain

Puis, lorsque je lance :
Code: Tout sélectionner
sudo update-grub
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-4.4.0-57-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-57-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-53-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-53-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
fait

Curieux, Il ne me trouve pas Windows 10 !!!
Ci joint le Boot-Info
http://paste2.org/zHH05h6I
Merci pour votre aide.
Dernière édition par bcaulier le 02 Jan 2017, 14:10, édité 1 fois.
bcaulier
 
Messages: 40
Inscription: 15 Mai 2016, 09:33

Re: GRUB ne détecte pas windows 10 après l'installation

de bcaulier 02 Jan 2017, 14:09

J'ai trouvé comment débloquer ce problème :
Le fichier /etc/default/grub contenait l'option :

Code: Tout sélectionner
GRUB_DISABLE_OS_PROBER="true"


en passant cette option à "false", puis en relançant
Code: Tout sélectionner
sudo update-grub
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-4.4.0-57-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-57-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-53-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-53-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Windows 10 (loader) trouvé sur /dev/sda1
fait

Il trouve Win10 !!
En rebootant, je trouve bien Win10 que je peux lancer sans soucis.
pingux
 
Messages: 2291
Inscription: 28 Déc 2011, 19:19
Localisation: Belgique

Re: [Resolu] GRUB ne détecte pas windows 10 après l'installa

de pingux 03 Jan 2017, 17:25

Hello bcaulier, merci pour le retour d'expérience. ;)
Et meilleurs vœux pour l'année 2017.
Dura Lex sed Lex
Retourner vers Xubuntu

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité