Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Apt-get -f install problème

27 sept. 2017, 01:05

Bonsoir

Après différents bugs mineurs, je souhaite réparer ma version proprement.
J'ai donc regardé différents posts et suivis ces commandes:

sudo apt-get update
sudo dpkg --configure -a
sudo apt-get -f install

Sauf que cette dernière est interrompue: dpkg:erreur de traitement de l'archive /var/...., impossible de copier les données extraites... échec d'écriture (aucun espace...)

J'ai donc tenté les suivantes:

sudo apt-get clean
sudo apt-get autoclean

sudo apt-get autoremove

Mais cette dernière rapporte également une erreur:

"Les paquets suivants contiennent des dépendances non satisfaites:
linux-image-extra-4.4.0-96-generic : Dépend : linux-image-4.4.0-96-generic mais il n'est pas installé
linux-image-generic : Dépend : linux-image-4.4.0-96-generic mais il n'est pas installé
linux-signed-image-4.4.0-96-generic : Dépend : linux-image-4.4.0-96-generic (= 4.4.0-96.119) mais il n'est pas installé"

Et on m'invite à utiliser la commande "apt-get -f install"

Et je tourne donc en rond entre ces différents points :/

Aidez-moi s'il vous plaît :p
Salutations, Grégoire.

trimardeur
Messages : 177
Enregistré le : 13 juil. 2016, 11:33
Contact : Envoyer un message privé

Re: Apt-get -f install problème

27 sept. 2017, 11:28

Bonjour,

- J'ai eu une fois le même problème, Il faut faire un nettoyage, avec le commandes suivantes en mode Root.

- # sudo apt-get autoclean ,les .deb téléchargés sont stockés dans /var/cache/apt/archives. autoclean: supprime les archives obsolètes.


- # apt-get , clean (efface tous les packages en cache.
Amitié, Daniel.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

28 sept. 2017, 18:54

Bonjour Daniel, merci de m'avoir répondu.

J'avais déjà effectué les opérations autoclean et clean. Et je les avais effectué en mode root (avec "sudo") devant.
Cependant rien n'y change. Toujours le même message d'erreur suivant:

___________________________________________________________________________________________________________________________________________

gregoire@gregoire-N2x0LU:~$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
libgles1-mesa libmircommon5:i386 linux-headers-4.4.0-21
linux-headers-4.4.0-21-generic linux-headers-4.4.0-31
linux-headers-4.4.0-31-generic linux-headers-4.4.0-57
linux-headers-4.4.0-57-generic linux-headers-4.4.0-59
linux-headers-4.4.0-59-generic linux-headers-4.4.0-64
linux-headers-4.4.0-64-generic linux-headers-4.4.0-66
linux-headers-4.4.0-66-generic linux-headers-4.4.0-72
linux-headers-4.4.0-72-generic linux-image-4.4.0-21-generic
linux-image-4.4.0-31-generic linux-image-4.4.0-57-generic
linux-image-4.4.0-59-generic linux-image-4.4.0-64-generic
linux-image-4.4.0-66-generic linux-image-4.4.0-72-generic
linux-image-extra-4.4.0-21-generic linux-image-extra-4.4.0-31-generic
linux-image-extra-4.4.0-57-generic linux-image-extra-4.4.0-59-generic
linux-image-extra-4.4.0-64-generic linux-image-extra-4.4.0-66-generic
linux-image-extra-4.4.0-72-generic linux-signed-image-4.4.0-21-generic
linux-signed-image-4.4.0-31-generic linux-signed-image-4.4.0-57-generic
linux-signed-image-4.4.0-59-generic linux-signed-image-4.4.0-64-generic
linux-signed-image-4.4.0-66-generic linux-signed-image-4.4.0-72-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
linux-image-4.4.0-96-generic
Paquets suggérés :
fdutils linux-doc-4.4.0 | linux-source-4.4.0 linux-tools
Les NOUVEAUX paquets suivants seront installés :
linux-image-4.4.0-96-generic
0 mis à jour, 1 nouvellement installés, 0 à enlever et 131 non mis à jour.
12 partiellement installés ou enlevés.
Il est nécessaire de prendre 21,9 Mo dans les archives.
Après cette opération, 67,0 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-image-4.4.0-96-generic amd64 4.4.0-96.119 [21,9 MB]
21,9 Mo réceptionnés en 4s (5 246 ko/s)
(Lecture de la base de données... 466924 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-image-4.4.0-96-generic_4.4.0-96.119_amd64.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.4.0-96-generic /boot/vmlinuz-4.4.0-96-generic
Done.
Dépaquetage de linux-image-4.4.0-96-generic (4.4.0-96.119) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/linux-image-4.4.0-96-generic_4.4.0-96.119_amd64.deb (--unpack) :
impossible de copier les données extraites pour « ./boot/vmlinuz-4.4.0-96-generic » vers « /boot/vmlinuz-4.4.0-96-generic.dpkg-new » : échec d'écriture (Aucun espace disponible sur le périphérique)
Aucun rapport « apport » n'a été créé car un disque plein a été signalé
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-96-generic /boot/vmlinuz-4.4.0-96-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-96-generic /boot/vmlinuz-4.4.0-96-generic
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/linux-image-4.4.0-96-generic_4.4.0-96.119_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
gregoire@gregoire-N2x0LU:~$

____________________________________________________________________________________________________________________
Salutations, Grégoire.

trimardeur
Messages : 177
Enregistré le : 13 juil. 2016, 11:33
Contact : Envoyer un message privé

Re: Apt-get -f install problème

29 sept. 2017, 07:53

Bonjour,

- La partition système est peut être pleine, Fait un clique droit dessus et clique sur propriétés et la tu verras dans la ligne utilisation l'espace libre qu'il te reste.
Amitié, Daniel.

barbatux
Messages : 354
Enregistré le : 27 avr. 2012, 11:29
Contact : Envoyer un message privé

Re: Apt-get -f install problème

29 sept. 2017, 11:21

Bonjour,

Apparemment le dernier noyau n'est pas bien installé ; est-ce que tu démarres sur un ancien noyau? (au démarrage dans le grub, choisir un noyau précédent)

trimardeur
Messages : 177
Enregistré le : 13 juil. 2016, 11:33
Contact : Envoyer un message privé

Re: Apt-get -f install problème

29 sept. 2017, 16:22

Bonjour,

- Tu peux essayer de démarrer à partir d'un ancien noyau mais je ne suis pas sur que tu arrive à corriger ton problème.

- Par contre vérifie a l'aide tu gestionnaire de paquet Synaptic si tu n'a pas des paquets cassés. ( Menu filtres personnels, Cassés ).
Amitié, Daniel.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

29 sept. 2017, 17:50

D'accord les gars merci

En effet, le dossier /boot est plein!!! 0 octet de libre sur 495.6 Mo. Je ne suis pas bien sûr de ce que je vais devoir supprimer cela dit.

Oui, j'ai des paquets cassés, puisque en haut à droite il y a un petit panneau sens interdit m'indiquant notamment: "Erreur: nb de paquets cassés > 0"
Via cet onglet je peux réparer et c'est là qu'il me dit qu'il manque de l'espace dans le dossier /Boot! (Avant ça je ne comprennais pas où l'espace manquait puisque j'ai 85Go de libre sur le DD système, et je ne pensais pas qu'il y avait une partie réservée à l'OS sur linux aussi....

Concernant Grub, oui lorsqu'il se lance au démarrage du PC (aléatoirement d'ailleurs puisque je ne sais pas vrmt cmt le faire apparaître), il me propose 2 versions d'ubuntu mais elles ont exactement le même nom. De même dans le BIOS, il me propose 2 versions sur lesquelles booter, sans les distinguer ne serait-ce qu'avec une lettre ou un chiffre.

Enfin, concernant synaptic, je n'ai pas le logiciel, mais comme pour Grub, si ça se trouve je l'ai sans le savoir.....

Bref, excusez un peu mon ignorance je suis un vrai novice de Linux!
Salutations, Grégoire.

trimardeur
Messages : 177
Enregistré le : 13 juil. 2016, 11:33
Contact : Envoyer un message privé

Re: Apt-get -f install problème

30 sept. 2017, 08:39

Bonjour,

- Je te conseille de ne pas toucher au dossier boot car tu risquerais de ne plus pouvoir démarrer.

- Essaye de faire de faire les commande " df -h " et " df -i" et relance les commandes précédentes.

sudo apt-get update
sudo dpkg --configure -a
sudo apt-get -f install
Amitié, Daniel.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

30 sept. 2017, 13:04

Bonjour Daniel,

Oui d'accord je vais éviter d'y toucher manuellement.
J'ai effectué les opérations que tu me conseilles. Toujours cette même erreur d'espace disque... Voilà les sorties:

gregoire@gregoire-N2x0LU:~$ sudo df -h
[sudo] Mot de passe de gregoire :
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
udev 902M 0 902M 0% /dev
tmpfs 185M 6,0M 179M 4% /run
/dev/mapper/xubuntu--vg-root 115G 32G 78G 29% /
tmpfs 922M 140K 922M 1% /dev/shm
tmpfs 5,0M 4,0K 5,0M 1% /run/lock
tmpfs 922M 0 922M 0% /sys/fs/cgroup
/dev/sda2 473M 471M 0 100% /boot
/dev/sda1 511M 3,4M 508M 1% /boot/efi
tmpfs 185M 4,0K 185M 1% /run/user/108
tmpfs 185M 32K 185M 1% /run/user/1000

gregoire@gregoire-N2x0LU:~$ sudo df -i
Sys. de fichiers Inœuds IUtil. ILibre IUti% Monté sur
udev 230814 513 230301 1% /dev
tmpfs 236011 733 235278 1% /run
/dev/mapper/xubuntu--vg-root 7634944 617472 7017472 9% /
tmpfs 236011 4 236007 1% /dev/shm
tmpfs 236011 6 236005 1% /run/lock
tmpfs 236011 16 235995 1% /sys/fs/cgroup
/dev/sda2 124928 341 124587 1% /boot
/dev/sda1 0 0 0 - /boot/efi
tmpfs 236011 12 235999 1% /run/user/108
tmpfs 236011 22 235989 1% /run/user/1000

gregoire@gregoire-N2x0LU:~$ sudo apt-get update
Atteint:1 http://archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://archive.canonical.com/ubuntu xenial InRelease
Atteint:3 http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial InRelease
Réception de:4 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Réception de:5 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Réception de:6 http://archive.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Réception de:7 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [634 kB]
Réception de:8 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [606 kB]
Réception de:9 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [305 kB]
Réception de:10 http://archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [217 kB]
Réception de:11 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [539 kB]
Réception de:12 http://archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [514 kB]
Réception de:13 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [172 kB]
Réception de:14 http://archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [234 kB]
Réception de:15 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5 888 B]
Réception de:16 http://archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3 328 B]
Réception de:17 http://archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [4 588 B]
Réception de:18 http://archive.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [60,2 kB]
Réception de:19 http://archive.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [62,6 kB]
Réception de:20 http://archive.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [49,2 kB]
Réception de:21 http://archive.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [69,8 kB]
3 784 ko réceptionnés en 2s (1 644 ko/s)
Lecture des listes de paquets... Fait


gregoire@gregoire-N2x0LU:~$ sudo dpkg --configure -a
Paramétrage de linux-image-extra-4.4.0-83-generic (4.4.0-83.106) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-83-generic

gzip: stdout: No space left on device
E: mkinitramfs failure find 141 cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.4.0-83-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erreur de traitement du paquet linux-image-extra-4.4.0-83-generic (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de linux-signed-image-4.4.0-96-generic :
linux-signed-image-4.4.0-96-generic dépend de linux-image-4.4.0-96-generic (= 4.4.0-96.119) ; cependant :
Le paquet linux-image-4.4.0-96-generic n'est pas installé.

dpkg: erreur de traitement du paquet linux-signed-image-4.4.0-96-generic (--configure) :
problèmes de dépendances - laissé non configuré
Paramétrage de initramfs-tools (0.122ubuntu8.8) ...
update-initramfs: deferring update (trigger activated)
dpkg: des problèmes de dépendances empêchent la configuration de linux-image-extra-4.4.0-96-generic :
linux-image-extra-4.4.0-96-generic dépend de linux-image-4.4.0-96-generic ; cependant :
Le paquet linux-image-4.4.0-96-generic n'est pas installé.

dpkg: erreur de traitement du paquet linux-image-extra-4.4.0-96-generic (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de linux-image-generic :
linux-image-generic dépend de linux-image-4.4.0-96-generic ; cependant :
Le paquet linux-image-4.4.0-96-generic n'est pas installé.
linux-image-generic dépend de linux-image-extra-4.4.0-96-generic ; cependant :
Le paquet linux-image-extra-4.4.0-96-generic n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-image-generic (--configure) :
problèmes de dépendances - laissé non configuré
Paramétrage de linux-firmware (1.157.11) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-83-generic

gzip: stdout: No space left on device
E: mkinitramfs failure find 141 cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.4.0-83-generic with 1.
dpkg: erreur de traitement du paquet linux-firmware (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de linux-image-4.4.0-87-generic (4.4.0-87.110) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
vmlinuz(/boot/vmlinuz-4.4.0-87-generic
) points to /boot/vmlinuz-4.4.0-87-generic
(/boot/vmlinuz-4.4.0-87-generic) -- doing nothing at /var/lib/dpkg/info/linux-image-4.4.0-87-generic.postinst line 491.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-87-generic

gzip: stdout: No space left on device
E: mkinitramfs failure find 141 cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.4.0-87-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.4.0-87-generic.postinst line 1052.
dpkg: erreur de traitement du paquet linux-image-4.4.0-87-generic (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 2
dpkg: des problèmes de dépendances empêchent la configuration de linux-signed-image-generic :
linux-signed-image-generic dépend de linux-signed-image-4.4.0-96-generic ; cependant :
Le paquet linux-signed-image-4.4.0-96-generic n'est pas encore configuré.
linux-signed-image-generic dépend de linux-image-extra-4.4.0-96-generic ; cependant :
Le paquet linux-image-extra-4.4.0-96-generic n'est pas encore configuré.
linux-signed-image-generic dépend de linux-firmware ; cependant :
Le paquet linux-firmware n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-signed-image-generic (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de linux-signed-image-4.4.0-87-generic :
linux-signed-image-4.4.0-87-generic dépend de linux-image-4.4.0-87-generic (= 4.4.0-87.110) ; cependant :
Le paquet linux-image-4.4.0-87-generic n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-signed-image-4.4.0-87-generic (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de linux-generic :
linux-generic dépend de linux-image-generic (= 4.4.0.96.101) ; cependant :
Le paquet linux-image-generic n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-generic (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de linux-image-extra-4.4.0-87-generic :
linux-image-extra-4.4.0-87-generic dépend de linux-image-4.4.0-87-generic ; cependant :
Le paquet linux-image-4.4.0-87-generic n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-image-extra-4.4.0-87-generic (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de linux-signed-generic :
linux-signed-generic dépend de linux-signed-image-generic (= 4.4.0.96.101) ; cependant :
Le paquet linux-signed-image-generic n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-signed-generic (--configure) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour initramfs-tools (0.122ubuntu8.8) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-83-generic

gzip: stdout: No space left on device
E: mkinitramfs failure find 141 cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.4.0-83-generic with 1.
dpkg: erreur de traitement du paquet initramfs-tools (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
linux-image-extra-4.4.0-83-generic
linux-signed-image-4.4.0-96-generic
linux-image-extra-4.4.0-96-generic
linux-image-generic
linux-firmware
linux-image-4.4.0-87-generic
linux-signed-image-generic
linux-signed-image-4.4.0-87-generic
linux-generic
linux-image-extra-4.4.0-87-generic
linux-signed-generic
initramfs-tools


gregoire@gregoire-N2x0LU:~$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
libgles1-mesa libmircommon5:i386 linux-headers-4.4.0-21 linux-headers-4.4.0-21-generic linux-headers-4.4.0-31 linux-headers-4.4.0-31-generic linux-headers-4.4.0-57
linux-headers-4.4.0-57-generic linux-headers-4.4.0-59 linux-headers-4.4.0-59-generic linux-headers-4.4.0-64 linux-headers-4.4.0-64-generic linux-headers-4.4.0-66
linux-headers-4.4.0-66-generic linux-headers-4.4.0-72 linux-headers-4.4.0-72-generic linux-image-4.4.0-21-generic linux-image-4.4.0-31-generic linux-image-4.4.0-57-generic
linux-image-4.4.0-59-generic linux-image-4.4.0-64-generic linux-image-4.4.0-66-generic linux-image-4.4.0-72-generic linux-image-extra-4.4.0-21-generic linux-image-extra-4.4.0-31-generic
linux-image-extra-4.4.0-57-generic linux-image-extra-4.4.0-59-generic linux-image-extra-4.4.0-64-generic linux-image-extra-4.4.0-66-generic linux-image-extra-4.4.0-72-generic
linux-signed-image-4.4.0-21-generic linux-signed-image-4.4.0-31-generic linux-signed-image-4.4.0-57-generic linux-signed-image-4.4.0-59-generic linux-signed-image-4.4.0-64-generic
linux-signed-image-4.4.0-66-generic linux-signed-image-4.4.0-72-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
linux-image-4.4.0-96-generic
Paquets suggérés :
fdutils linux-doc-4.4.0 | linux-source-4.4.0 linux-tools
Les NOUVEAUX paquets suivants seront installés :
linux-image-4.4.0-96-generic
0 mis à jour, 1 nouvellement installés, 0 à enlever et 131 non mis à jour.
12 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/21,9 Mo dans les archives.
Après cette opération, 67,0 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 466924 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-image-4.4.0-96-generic_4.4.0-96.119_amd64.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.4.0-96-generic /boot/vmlinuz-4.4.0-96-generic
Done.
Dépaquetage de linux-image-4.4.0-96-generic (4.4.0-96.119) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/linux-image-4.4.0-96-generic_4.4.0-96.119_amd64.deb (--unpack) :
impossible de copier les données extraites pour « ./boot/vmlinuz-4.4.0-96-generic » vers « /boot/vmlinuz-4.4.0-96-generic.dpkg-new » : échec d'écriture (Aucun espace disponible sur le périphérique)
Aucun rapport « apport » n'a été créé car un disque plein a été signalé
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-96-generic /boot/vmlinuz-4.4.0-96-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-96-generic /boot/vmlinuz-4.4.0-96-generic
The link /initrd.img is a damaged link
Removing symbolic link initrd.img
you may need to re-run your boot loader[grub]
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/linux-image-4.4.0-96-generic_4.4.0-96.119_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Salutations, Grégoire.

trimardeur
Messages : 177
Enregistré le : 13 juil. 2016, 11:33
Contact : Envoyer un message privé

Re: Apt-get -f install problème

30 sept. 2017, 14:26

Bonjour,

- Il que tu arrive à supprimer les anciens noyaux pour faire la mise à jour.

- Regarde sur cette page. ou celle-ci.
Amitié, Daniel.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

30 sept. 2017, 17:25

Bonjour Daniel,

D'accord merci je vais regarder ça de ce pas.
Salutations, Grégoire.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

30 sept. 2017, 18:31

Rebonjour,

J'ai essayé kclean toujours rien.
Contre vos avis j'ai tout de même essayé de manuellement supprimer les grosses archives gzip "initrd.img-4-4.0-31-generic" et les suivantes 57 59 64 et 66. Sans succès, le répertoire est bien entendu bloqué en lecture seule.

Enfin j'ai tenté la commande suivante

Code : Tout sélectionner

sudo rm -fr /usr/src/linux-headers-4.4.0-31-generic
Ainsi que le même code avec le numéro de ces compères.

Pour aller plus loin, j'ai voulu DL synaptic via ce lien https://doc.ubuntu-fr.org/synaptic et c'est une nouvelle fois "Logiciels" qui rencontre un problème "no file_to_app results to show".

Pour vous aider, voici le contenu de mon dossier /boot: Image
Salutations, Grégoire.

trimardeur
Messages : 177
Enregistré le : 13 juil. 2016, 11:33
Contact : Envoyer un message privé

Re: Apt-get -f install problème

30 sept. 2017, 18:58

Bonjour,

- Quelle méthode utilisé vous pour installer " Synaptique ", avez vous fait une recherche directement dans " Logiciels ".
Amitié, Daniel.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

01 oct. 2017, 20:28

Bonsoir Daniel,

Oui j'ai essayé des deux façons...
Mon interface graphique bloque une fois que j'ai cliqué sur "installer". La barre bleue reste coincée après 2mm de chargement.
Via les lignes de commande, voici la sortie:

Code : Tout sélectionner

gregoire@gregoire-N2x0LU:~$ sudo apt-get install synaptic
[sudo] Mot de passe de gregoire : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 linux-image-extra-4.4.0-96-generic : Dépend: linux-image-4.4.0-96-generic mais ne sera pas installé
 linux-image-generic : Dépend: linux-image-4.4.0-96-generic mais ne sera pas installé
 linux-signed-image-4.4.0-96-generic : Dépend: linux-image-4.4.0-96-generic (= 4.4.0-96.119) mais ne sera pas installé
 synaptic : Dépend: libept1.5.0 mais ne sera pas installé
            Recommande: rarian-compat mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution). 
La boucle recommence.
Salutations, Grégoire.

trimardeur
Messages : 177
Enregistré le : 13 juil. 2016, 11:33
Contact : Envoyer un message privé

Re: Apt-get -f install problème

02 oct. 2017, 12:12

Bonjour,

- Peux tu essayer " sudo apt-get install linux-headers-4.4.0-96-generic ".
Amitié, Daniel.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

02 oct. 2017, 16:26

Bonjour Daniel,

Voici la sortie:

Code : Tout sélectionner

gregoire@gregoire-N2x0LU:~$ sudo apt-get install linux-headers-4.4.0-96-generic
[sudo] Mot de passe de gregoire : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
linux-headers-4.4.0-96-generic is already the newest version (4.4.0-96.119).
linux-headers-4.4.0-96-generic passé en « installé manuellement ».
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 linux-image-extra-4.4.0-96-generic : Dépend: linux-image-4.4.0-96-generic mais ne sera pas installé
 linux-image-generic : Dépend: linux-image-4.4.0-96-generic mais ne sera pas installé
 linux-signed-image-4.4.0-96-generic : Dépend: linux-image-4.4.0-96-generic (= 4.4.0-96.119) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
Je me demande si une réinstallation vierge ne serait pas plus appropriée? Je n'ai rien à conserver que de petits fichiers déjà sauvés sur clé USB.
Salutations, Grégoire.

barbatux
Messages : 354
Enregistré le : 27 avr. 2012, 11:29
Contact : Envoyer un message privé

Re: Apt-get -f install problème

02 oct. 2017, 16:39

Bonjour,
peux-tu faire

Code : Tout sélectionner

uname -r
pour savoir sur quel noyau tu démarres?
Si la réponse est "4 4 0 96" , ce noyau est incomplet et tu ne pourras rien faire (à partir de ce noyau).

D'où l'idée de démarrer sur un noyau précédent (tu dois pouvoir faire apparaître le grub en tapotant la touche tabulation, puis tu descends vers autres démarrages et dans le panneau suivant tu sélectionnes un noyau précédent qui doit être valide, parce qu’entier)
Une fois démarré, tu fais le ménage des anciens noyaux, et ensuite une fois qu'il y a de la place, tu devrais pouvoir compléter l'installation du noyau (et du reste).
Voilà l'idée.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

02 oct. 2017, 16:45

Bonjour barbatux,

Le terminal me dit que je démarre sur la version 4.4.0-83-generic. Sachant que je n'ai jamais choisi/changé le noyau sur lequel démarrer.
Selon ce que tu me dis, je devrai être en mesure de supprimer les anciens noyaux par le biais des commandes citée plus haut?
Salutations, Grégoire.

barbatux
Messages : 354
Enregistré le : 27 avr. 2012, 11:29
Contact : Envoyer un message privé

Re: Apt-get -f install problème

02 oct. 2017, 17:01

Si tu arrives à faire apparaitre le grub, genre :
Image
tu peux essayer soit un noyau précédent, soit le mode "recovery" (soit tant qu'à faire, un noyau précédent en mode recovery/dépannage).
https://doc.ubuntu-fr.org/recovery_mode
qui donne qqchose comme ça
Image
Dans cette console, tu peux essayer "clean" mais pas sur que ça fasse un autoremove, sinon en bas "root" te permet d'écrire les commandes (apt-get autoremove), et pas besoin d'écrire "sudo" avant car tu es déjà en root.
Si tu as besoin de faire des mises à jour, ou de réparer des paquets car cassés, il faudra d'abord établir la connexion en cliquant sur "réseau"( je crois), et dans ce cas il vaut mieux être connecté en filaire.

Si ça fait beaucoup de choses d'un coup, c'est normal, n'hésite pas à donner ton retour en fonction de ce que tu as fait. Et désélo, oups désolé, d'être un peu bordélique dans mes explications.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

02 oct. 2017, 17:48

Hehe pas de problème barbatux je te remercie.
J'ai du mal à entrer dans Grub car si je reste appuyé trop longtemps sur ESC il saute très rapidement la première fenetre contextuelle (ta photo 1), mais j'ai pris le coup de main.
En effet j'ai 3 options de boot pour chaque noyau; exemple type:

Ubuntu, avec Linux 4.4.0-83-generic
Ubuntu, avec Linux 4.4.0-83-generic (upstrat)
Ubuntu, avec Linux 4.4.0-83-generic (recovery mode)

Et ces 3 là déclinés en version 83 72 66 64 59 57 31 21.

Je vais suivre les étapes décrites dans ton lien, sur le recovery mode de mon avant-dernière version (72 ).
Modifié en dernier par Prydz le 02 oct. 2017, 18:00, modifié 1 fois.
Salutations, Grégoire.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

02 oct. 2017, 18:00

J'ai activé la prise en charge réseau en me connectant via Ethernet.
Le contrôle via Fsck rapporte un résultat assez imprécis mais tout semble OK
L'option Clean, quant à elle, sort toujours la même erreur: "

Code : Tout sélectionner

"Les paquets suivants contiennent des dépendances non satisfaites: 
linux-image-extra-4.4.0-96-generic : Dépend : linux-image-4.4.0-96-generic mais il n'est pas installé...etc

[...]

Essayez d'utiliser l'option apt-get -f install"
Je teste ensuite l'option dpkg:

Code : Tout sélectionner

Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done

Calcul des modiifications en cours 

[...]

Espace libre insuffisant sur le disque, veuillez "sudo apt-get clean"
Bref, rien n'y fait...
Salutations, Grégoire.

Prydz
Messages : 12
Enregistré le : 27 sept. 2017, 00:49
Contact : Envoyer un message privé

Re: Apt-get -f install problème

02 oct. 2017, 18:13

Un grand merci à vous deux pour ces conseils qui me seront certainement encore utiles dans le futur mais je vais pour l'instant réinstaller une version neuve afin de pouvoir pleinement utiliser ma machine cette semaine.
Salutations, Grégoire.

Retourner vers « Xubuntu »