Cet espace permet de solliciter aide et conseils sur Xubuntu.
Bienvenue à tous !
mterrisse
 
Messages: 3
Inscription: 27 Oct 2017, 23:55

Installation de Xubuntu 17.10 sur Asus Eee PC 1000H

de mterrisse 28 Oct 2017, 00:48

Bonjour à tous,

J'ai installé il y a quelques jours Xubuntu 17.10 sur un Asus Eee PC 1000H, initialement sous Windows XP, et cela n'a pas été sans mal.
Du coup je souhaite indiquer ici comment j'ai résolu mes problèmes en espérant que cela puisse aider d'autres que moi.
Allons droit au but, la solution pour que l'écran fonctionne c'est
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=0x0318"
dans /etc/defaults/grub, puis sudo update-grub, sudo reboot

En détails :
1/ Mise à jour du BIOS
Sous Windows XP il y a un outil Asus préinstallé pour voir la version du bios. La dernière version est 2204. Si vous êtes sous une version précédente (j'étais sur la version 2102), je vous conseille de faire la mise à jour depuis Windows XP, parce qu'avec l'outil d'Asus c'est bien pratique.
Cherchez 1000H-ASUS-2204.zip surle web, dézippez le en 1000H-ASUS-2204.rom et mettez à jour le bios avec l'outil.
2/ Préparez une clé USB bootable à partir de l'image iso de Xubuntu 17.10 32 bits (je ne détaille pas comment, c'est déjà très bien expliqué par plein de gens)
3/ A savoir : inutile de modifier les options du BIOS pour démarrer sur la clé USB, les options par défaut conviennent très bien. Il faut juste savoir que si on fait escape, escape, escape, ... pendant l'écran de démarrage du BIOS, il nous demande sur quel disque on veut démarrer et on peut alors choisir la clé USB.
4/ Démarrez donc sur la clé USB et installez Xubuntu. Au redémarrage vous verrez que cela ne marche pas du tout, l'écran est tout pourri avec un Xubuntu de deux centimètres à droite de l'écran.
Pas de panique, redémarrez, et juste après l'écran du BIOS maintenez la touche majuscule gauche enfoncée pour entrer dans l'écran de configuration de grub. J'ai trouvé la procédure ici :
https://askubuntu.com/questions/38780/h ... led-ubuntu
Vous pouvez alors démarrer normalement en spécifiant après quiet splash :
- soit nomodeset
- soit i915.modeset=0
- soit vga=0x0318
5/ Un fois que cela a démarré, vous pouvez faire Ctrl + Alt + F1, vous loguer, puis
sudo nano /etc/defaults/grub
changez la ligne GRUB_CMDLINE_LINUX_DEFAULT comme ceci
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=0x0318"
Ctrl + x pour sauver et quitter
sudo reboot

Et voilà.
Bon, je dois quand même expliquer comment j'en suis arrivé à la conclusion qu'il fallait spécifier vga=0x0318.
En fait déjà sous Windows XP j'avais pu noter que la carte video proposait des résolutions que l'écran ne pouvait pas afficher. Donc quand j'ai eu le problème, j'ai démarré avec nomodeset dans grub, puis j'ai fait
sudo apt-get install hwinfo
sudo hwinfo --framebuffer
On voit là toutes les résolutions supportées par la carte vidéo, et la plupart sont effectivement bien au delà de ce que peut afficher l'écran.
La résolution sous Windows étant de 1024x600, j'ai choisi la plus proche, celle dont le code hexadécimal est 0x0318
A noter qu'on peut normalement utiliser GRUB_GFXMODE au lieu de vga=xxx, mais j'ai essayé et cela ne marche pas.

Une dernière chose :
La première installation de Xubuntu ne marchant pas, j'avais décidé de réinstaller en ne mettant pas les pilotes tiers propriétaires, et l'installation a échoué. Pourquoi ? Parce que c'est un BIOS legacy et qu'il faut pour installer que le secteur de boot soit de type msdos. Or à la première installation j'avais choisi l'option recommandée qui disait de créer des partitions logiques plus facilement retaillables, et cela a changé le type de boot.
Solution si cela vous arrive : démarrez sur la clé USB, allez dans le gestionnaire de partition, démontez tout et spécifiez que le type de secteur de boot est msdos.
Alors vous pourrez réinstaller Xubuntu sans erreur.
Pour ma part j'ai choisi une partition de swap de 2048 Mo (deux fois la RAM) et tout le reste du disque pour une partition ext4 montée sur /

Voilà, j'espère que cela pourra aider quelqu'un.
Maintenant mon Eee PC 1000H fonctionne parfaitement bien.

Michel
mterrisse
 
Messages: 3
Inscription: 27 Oct 2017, 23:55

Re: Installation de Xubuntu 17.10 sur Asus Eee PC 1000H

de mterrisse 28 Oct 2017, 13:50

Bien sûr vous n'êtes pas obligés d'écrire vga=0x0318, vous pouvez écrire vga=0x318 ou en décimal vga=792, j'écris 0x0318 juste pour coller à la sortie de sudo hwinfo --framebuffer.
J'ai lu qu'on peut aussi écrire vga=ask, mais je n'ai pas essayé.

Michel
mterrisse
 
Messages: 3
Inscription: 27 Oct 2017, 23:55

Re: Installation de Xubuntu 17.10 sur Asus Eee PC 1000H

de mterrisse 29 Oct 2017, 12:47

Bonjour,

En me relisant j'ai noté que j'ai écrit par erreur /etc/defaults/grub, or il n'y a pas de s, c'est /etc/default/grub, désolé.

Michel
quentin
 
Messages: 1
Inscription: 22 Nov 2017, 19:18

Re: Installation de Xubuntu 17.10 sur Asus Eee PC 1000H

de quentin 22 Nov 2017, 19:32

MERCI, MERCI, MERCI

Tu me sauve de la depression haha, j'ai passer la journé a essayé de comprendre pourquoi cela me faisait ca.
j'ai réinstallé aux moins 4 fois xubuntu, j'ais cherché les drivers de ma carte graphique et j'ai même télécharger lubuntu pour voir si le problème persisté :x

encore merci haha
Retourner vers Xubuntu

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités