Cet espace permet de solliciter aide et conseils concernant l'installation, la personnalisation et l'utilisation de Xubuntu.
Bienvenue à tous !
Slander
 
Messages: 3
Inscription: 12 Nov 2018, 20:05

Problème de souris qui arrête de fonctionner

de Slander 19 Nov 2018, 19:57

Bonjour à tous et toutes,

Je me retrouve depuis quelques semaines face à un problème assez chiant ! Je m'explique :

Je possède un PC portable ASUS GL742VW sous Xubuntu 18.04 LTS 64 bits sur lequel je branche régulièrement une souris USB qui fonctionne parfaitement. Mais parfois, lorsque je la branche, elle ne fonctionne pas... Du moins dans ma session ! Parce que si je fais un Ctrl + Alt + L pour verrouiller ma session et retourner à lightdm, là elle fonctionne parfaitement (sans l'avoir débranchée ni rien) !

Si je me reconnecte à ma session, elle ne fonctionne plus. Si je me re-verrouille et reviens à nouveau sur lightdm, elle fonctionne toujours parfaitement ! C'est à n'y rien comprendre ! À croire qu'il y a un truc dans ma session qui empêche la souris USB de fonctionner.

J'ai également testé avec d'autres souris USB de marques différentes et sur tous les ports USB de ma machine mais j'ai exactement le même problème ! Donc inutile de vous préciser que j'ai fait des recherches et que certains problèmes similaires ne m'ont pas apporté de solution. Les commandes du style "lsusb" et "dmesg" ne sont d'aucune utilité puisque ma souris fonctionne parfaitement en dehors de ma session ! Par exemple, si ma souris ne fonctionne pas dans ma session, je verrouille ma session et ouvre une session "invité" et là la souris marche parfaitement.

Je vous colle tout de même un dmesg après branchement de la souris (elle ne fonctionne pas) :
Code: Tout sélectionner
[347108.358119] usb 1-1: new low-speed USB device number 68 using xhci_hcd
[347108.514792] usb 1-1: New USB device found, idVendor=1c4f, idProduct=0034
[347108.514798] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[347108.514802] usb 1-1: Product: Usb Mouse
[347108.514805] usb 1-1: Manufacturer: SIGMACHIP
[347108.517739] input: SIGMACHIP Usb Mouse as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0/0003:1C4F:0034.0023/input/input77
[347108.517960] hid-generic 0003:1C4F:0034.0023: input,hidraw0: USB HID v1.10 Mouse [SIGMACHIP Usb Mouse] on usb-0000:00:14.0-1/input0

Comme vous pouvez le constater, le numéro de dispositif est élevé (ici 68) mais ça s'explique par le fait que dès que je bouge la souris, elle se déconnecte et se reconnecte de suite après :
Code: Tout sélectionner
[347330.140886] usb 1-1: USB disconnect, device number 68
[347330.447907] usb 1-1: new low-speed USB device number 69 using xhci_hcd
...

Le pire c'est que si je démarre mon PC (après une extinction, pas une veille ou un truc du genre) et branche ma souris elle fonctionne parfaitement. Si je la débranche et rebranche 10 fois d'affilées, elle fonctionne toujours parfaitement ! Mais de temps en temps, je la branche et elle ne fonctionne plus dans ma session... Il m'est arrivé 1 seule fois la même chose avec le touchpad il y a 5 semaines, mais pas depuis... Et c'est toujours quand j'ai super besoin de ma souris bien sûr !

Si je ferme ma session et la ré-ouvre (pas juste un verrouillage), la souris marche parfaitement (sans l'avoir débranchée). J'ai pensé à un problème d'auto-mise en veille de l'USB pour non utilisation du périphérique par économie d'énergie, mais vu que si je sors de la session la souris fonctionne, je ne suis pas vraiment sûr de ça.

Si jamais vous avez des idées ou besoin de précisions, je suis toutes ouïes !

Slander

PS : J'ai Xubuntu depuis des années, les problèmes ont commencés avec la version 16.04 LTS du jour au lendemain (probablement après une MAJ, mais je n'en suis pas sûr). Depuis j'ai réinstallé plusieurs fois l'OS et à chaque fois ça déconne par intermittence...
garibald
 
Messages: 88
Inscription: 15 Déc 2011, 13:17

Re: Problème de souris qui arrête de fonctionner

de garibald 26 Nov 2018, 12:01

Je dirais qu'il y a sur ton PC un driver de souris qu'il faudrait supprimer, un qui a été installé sur ta session uniquement.
Pour ça faudrait peut être voire icihttps://askubuntu.com/questions/9749 ... -with-xfce
Slander
 
Messages: 3
Inscription: 12 Nov 2018, 20:05

Re: Problème de souris qui arrête de fonctionner

de Slander 27 Nov 2018, 01:00

Bonjour et merci de ta réponse.

Par contre j'ai voulu jeter un œil sur ton lien mais j'obtiens un 404... En ce qui concerne un driver installé, je n'en ai pas installé manuellement en tous cas... J'attends ton retour pour pouvoir consulter ton lien.

Slander
Slander
 
Messages: 3
Inscription: 12 Nov 2018, 20:05

Re: Problème de souris qui arrête de fonctionner

de Slander 11 Déc 2018, 19:25

Bon je relance le fil puisque je n'ai toujours pas de solution et que ça commence à m'agacer menu ce problème de souris...
J'envisage sérieusement de changer de distri vu que je ne suis plus productif du coup !

En attendant, si vous avez des pistes, je vous écoute ! ;)

Garibald ne m'ayant pas répondu (même en privé) je n'ai pas pu approfondir son idée...

Slander
Retourner vers Xubuntu

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités