lenegip
Messages : 1
Enregistré le : 11 déc. 2012, 22:09
Contact : Envoyer un message privé

Pb de dual boot xubuntu 1210 & Win Me

12 déc. 2012, 19:58

Bonjour,
J'ai installé (après qqes galères) sur mon vieux PC (Bonne config pour l'année 2000) et sur 2 disques différents : Xubuntu V1210 & Win Me. Xubunt sur /dev/sda1 et Win Me sur /dev/sdb1.
Si je démarre au bios pas de soucis pour booter sur WinMe, il est nickel.
Si je démarre avec grub et que je boote sur Xubuntu, c'est nickel et je vois bien le 2ème disque avec Win Me.
Si je démarre avec grub et que je boote sur Win / .. / .. / l'écran reste figé couleur foncé.
J'ai fait des recherches sur les docs et les forums.
Sous Xubuntu en mode terminal sous /etc/grub.d (avec sudo) j'ai fait la manip suivante :
sauvegarde du répertoire /etc/grub.d
sudo chmod -x 30_os-prober (pour désactiver l'exécution de os-prober)
cp /etc/grub.d/40_custom /etc/grub.d/36_windows
j'ai ajouté le bloc ci dessous dans 36_windows :
menuentry "Windows"
{
set root=(hd1,1)
chainloader +1
}
sudo update-grub
Si je démarre ainsi avec grub et que je boote sur Windows : j'ai bien la fenêtre de Win Me qui s'affiche, écran bleu, invite du mot de passe, écran bleu, et ensuite erreur genre :
Erreur : OE : 0028 : C2A16366
je valide pour continuer, et hop une autre du même genre, je valide et là gros bruit, impossible de stopper au bouton de l'UC j'ai dû sortir la prise de l'alim.
Plus de peur que de mal, j'ai restauré /etc/grub.d, et j'ai vérifier les 2 OS tout va bien.
Xubuntu est installé sur un disque de 70 giga sur l'alim du disque.
Win Me est installé sur un 2d disque de 30 giga sur l'alim du lecteur de DVD.
J'ai vu que il fallait "mapper" si installé Windows ailleurs que sur le premier disque dur:
map (hd0) (hd1)
map (hd1) (hd0)
Mon pb :
quelle est la manip (syntaxe) précise à faire dans les fichiers de conf de grub, car je n'arrive pas à la trouver, et vu le bruit qu'a fait le PC j'ai la trouille de me planter.
Est ce que qq'un peut me dire quels fichiers je dois mettre à jour, quelle syntaxe, quelle manip ??
merci pour votre aide :)
Phil

kiwijuice
Messages : 6
Enregistré le : 17 déc. 2012, 10:08
Contact : Envoyer un message privé

Re: Pb de dual boot xubuntu 1210 & Win Me

18 déc. 2012, 18:56

Bonjour,

Il me semble que sous grub 2, les disques ne sont pas numeroté de 0, à X mais de 1, à X, ton sdb devrait donc s'appeler hd2,1, à verifier.

Sinon, as-tu bien redu ton fichier 36_windows executable ?

chmod +x /etc/grub.d/36_windows

Ce ne sont que des details puisque tu as visiblement reussi à botter sur windows, le problème n'est pas la, mais à tout hasard.

Bon courage

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Pb de dual boot xubuntu 1210 & Win Me

29 déc. 2012, 18:53

Bon, je remonte le sujet. Ma solution serait une manipulation matérielle, si l'interface des disques sont en PATA les nappes de celle-ci comportent 2 connecteurs. Mettre le disque wouindows à l'extrémité et le disque Xubuntu sur l'autre connecteur. Si linterface est SATA, mettre le disque wouindows sur le connecteur 0 et celui de Xubuntu sur le 1. Après cela il ne reste plus qu'à (ré) installer Grub sur le bon disque hda ou sda.
Dura Lex sed Lex

Retourner vers « Xubuntu »