benhux
Messages : 5
Enregistré le : 22 mai 2014, 21:30
Contact : Envoyer un message privé

Son micro très bas

22 mai 2014, 21:36

Bonjour,

J'essaye d'installer un programme qui enregistre des réunions.

Le son vient d'une table de mixage vers l'entrée line de la carte son.

Rien ne passe.

J'ai testé la sortie de la table de mixage en y branchant mon téléphone. La réunion s'enregistre parfaitement, le son est clair et net.

J'ai essayé avec 4 pc différents avec l'installation de cette application puis sans l'installation.

J'ai testé en installant Xubuntu 13.10 sur un pc puis en testant avec un casque équipé d'un micro. Rien. Puis en installant Xubuntu 14.04, idem.

J'ai fait d'autres tests en installant pavumeter et en modifiant les réglages de pulseaudio. Pour avoir quelque chose d'audible, il faut mettre tout au maximum avec bien entendu un son exécrable.

Help please.
Modifié en dernier par benhux le 24 mai 2014, 08:47, modifié 1 fois.

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Xubuntu 13.10|14.04 son micro très bas

22 mai 2014, 23:51

Hello benhux, pourrais tu nous dire quel programme tu utilises. En cliquant sur l'icône du son dans le tableau de bord supérieur puis sur "Paramètres sonore", l'onglet "Périphérique d'entrée", regarde (avec la table de mixage branchée) si le bon périphérique est bien coché, il y a une barre qui sert de vu-mètre, regarde si celle-ci varie bien quand la table émet.
Dura Lex sed Lex

benhux
Messages : 5
Enregistré le : 22 mai 2014, 21:30
Contact : Envoyer un message privé

Re: Xubuntu 13.10|14.04 son micro très bas

23 mai 2014, 10:28

Bonjour et merci.

Donc, je pars d'une toute nouvelle installation de Xubuntu 13.10 sur un Lenovo ThinkCentre MT-M 7066-CTO.

Au vu de http://download.lenovo.com/ibmdl/pub/pc ... 5c6524.pdf, la carte son devrait être une ALC662.

Bon, dans le tableau de bord supérieur, l'icône du son est grisée et est suivie de '--'.
PasDeSonIcone.png
J'ai du son sur youtube que je peux faliement régler avec la molette des hauts parleurs.

Par contre, j'ai lancé alsamixer dans une console et là, je peux monter et descendre le son. Je n'ai touché à rien d'autre.

Enfin, je précise que je dois faire ces réglages UNE seule fois. Une fois les réglages fait le pc sera utilisé par une asbl qui n'aura pas accès à ces réglages.

Merci

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Son micro très bas

24 mai 2014, 12:42

Il y a ICI les drivers pour ta carte son. Si tu rencontres des difficultés pour l'installation nous sommes à ta disposition pour te guider. ;)
Dura Lex sed Lex

benhux
Messages : 5
Enregistré le : 22 mai 2014, 21:30
Contact : Envoyer un message privé

Re: Son micro très bas

24 mai 2014, 14:12

Bonjour et merci,

Bon, j'ai téléchargé, dézippé et lancé la commande :

Code : Tout sélectionner

./configure --with-cards=hda-intel
J'ai ce résultat (avec pleins de checking avant):

Code : Tout sélectionner

checking for directory with kernel source... /lib/modules/3.11.0-12-generic/build
checking for directory with kernel build... /lib/modules/3.11.0-12-generic/build
checking for kernel linux/version.h ... no
The file /lib/modules/3.11.0-12-generic/build/include/INCLUDE_VERSION_H does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /lib/modules/3.11.0-12-generic/build).
Pour info, j'ai installé la version 13.10 de l'OS.

-edit-
Bon j'ai fait quelques recherches (quand même) :-)

C'est un problème de kernel. On dirait que je dois trouver les fichier zippés du kernel ou indiquer le chemin vers le noyau.

Pour info:

Code : Tout sélectionner

uname -r
3.11.0-12-generic

Code : Tout sélectionner

cat /proc/version
Linux version 3.11.0-12-generic (buildd@komainu) (gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu7) ) #19-Ubuntu SMP Wed Oct 9 16:12:00 UTC 2013
Je sèche là pour l'instant.

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Son micro très bas

24 mai 2014, 21:38

Hum, avant toute chose il faut installer les outils de compilation pour cela dans un terminal tu lances cette commande :

Code : Tout sélectionner

sudo apt-get install build-essential fakeroot checkinstall
Ensuite tu vas dans le répertoire ou tu as décompressé l'archive téléchargée "cd realtek-linux-audiopack-5.16" et là, tu lances la commande pour l'installation automatique :

Code : Tout sélectionner

sudo ./install
Et normalement après un reboot ta carte devrait fonctionner.
Dura Lex sed Lex

benhux
Messages : 5
Enregistré le : 22 mai 2014, 21:30
Contact : Envoyer un message privé

Re: Son micro très bas

25 mai 2014, 13:21

Merci,

Donc, j'ai lancé la commande:

Code : Tout sélectionner

sudo apt-get install build-essential fakeroot checkinstall
Pas de soucis, tout est installé.

Puis:

Code : Tout sélectionner

sudo ./install

Voici le résultat, je dirais que ça ne se passe pas bien.

Code : Tout sélectionner

sudo ./install 
.....Decompress Driver source v1.0.24-5.16rc25
Compile Driver........
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24
checking cross compile... 
checking for directory with ALSA kernel sources... /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/alsa-kernel
checking for directory with kernel source... /lib/modules/3.11.0-12-generic/build
checking for directory with kernel build... /lib/modules/3.11.0-12-generic/build
checking for kernel linux/version.h ... no
The file /lib/modules/3.11.0-12-generic/build/include/INCLUDE_VERSION_H does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /lib/modules/3.11.0-12-generic/build).
make all-deps
make[1]: entrant dans le répertoire « /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24 »
gcc utils/mod-deps.c -o utils/mod-deps
utils/mod-deps.c: In function ‘output_card_list’:
utils/mod-deps.c:1076:4: warning: format not a string literal and no format arguments [-Wformat-security]
    printf(card_name);
    ^
utils/mod-deps --basedir /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/alsa-kernel --hiddendir /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24 --versiondep /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/kconfig-vers --makeconf > toplevel.config.in
can't handle 'default SND_SEQUENCER && SND_RAWMIDI', translating as depends on
can't handle 'default SND_SEQUENCER && SND_OPL3_LIB', translating as depends on
can't handle 'default SND_SEQUENCER && SND_OPL4_LIB', translating as depends on
can't handle 'default SND_SEQUENCER && SND_SBAWE', translating as depends on
can't handle 'default SND_SEQUENCER && SND_EMU10K1', translating as depends on
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_ES1968 properly, supposing it's OK
can't handle word VIDEO_V4L2=y properly, supposing it's OK
can't handle word VIDEO_V4L2=SND_FM801 properly, supposing it's OK
can't handle 'default SND_FM801', translating as depends on
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_HDA_INTEL properly, supposing it's OK
can't handle word SND_HDA_INPUT_BEEP=y properly, supposing it's OK
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND properly, supposing it's OK
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_MAESTRO3 properly, supposing it's OK
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_USB_CAIAQ properly, supposing it's OK
utils/mod-deps --basedir /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/alsa-kernel --hiddendir /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24 --versiondep /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/kconfig-vers --acinclude > acinclude.m4
can't handle 'default SND_SEQUENCER && SND_RAWMIDI', translating as depends on
can't handle 'default SND_SEQUENCER && SND_OPL3_LIB', translating as depends on
can't handle 'default SND_SEQUENCER && SND_OPL4_LIB', translating as depends on
can't handle 'default SND_SEQUENCER && SND_SBAWE', translating as depends on
can't handle 'default SND_SEQUENCER && SND_EMU10K1', translating as depends on
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_ES1968 properly, supposing it's OK
can't handle word VIDEO_V4L2=y properly, supposing it's OK
can't handle word VIDEO_V4L2=SND_FM801 properly, supposing it's OK
can't handle 'default SND_FM801', translating as depends on
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_HDA_INTEL properly, supposing it's OK
can't handle word SND_HDA_INPUT_BEEP=y properly, supposing it's OK
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND properly, supposing it's OK
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_MAESTRO3 properly, supposing it's OK
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_USB_CAIAQ properly, supposing it's OK
utils/mod-deps --basedir /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/alsa-kernel --hiddendir /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24 --versiondep /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/kconfig-vers --include > include/config1.h.in
can't handle 'default SND_SEQUENCER && SND_RAWMIDI', translating as depends on
can't handle 'default SND_SEQUENCER && SND_OPL3_LIB', translating as depends on
can't handle 'default SND_SEQUENCER && SND_OPL4_LIB', translating as depends on
can't handle 'default SND_SEQUENCER && SND_SBAWE', translating as depends on
can't handle 'default SND_SEQUENCER && SND_EMU10K1', translating as depends on
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_ES1968 properly, supposing it's OK
can't handle word VIDEO_V4L2=y properly, supposing it's OK
can't handle word VIDEO_V4L2=SND_FM801 properly, supposing it's OK
can't handle 'default SND_FM801', translating as depends on
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_HDA_INTEL properly, supposing it's OK
can't handle word SND_HDA_INPUT_BEEP=y properly, supposing it's OK
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND properly, supposing it's OK
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_MAESTRO3 properly, supposing it's OK
can't handle word INPUT=y properly, supposing it's OK
can't handle word INPUT=SND_USB_CAIAQ properly, supposing it's OK
make[1]: quittant le répertoire « /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24 »

Please, run the configure script as first...

if [ -L /include/sound ]; then \
		rm -f /include/sound; \
		ln -sf /home/ecaussinnes/Téléchargements/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/include/sound /include/sound; \
	else \
		rm -rf /include/sound; \
		install -d -m 755 -g root -o root /include/sound; \
		for f in include/sound/*.h; do \
			install -m 644 -g root -o root $f /include/sound; \
		done \
	fi
install: impossible d'évaluer «include/sound/*.h»: Aucun fichier ou dossier de ce type
make: *** [install-headers] Erreur 1
Creating mixer?...done.
Creating sequencer...done.
Creating midi0?...done.
Creating dsp?...done.
Creating audio?...done.
Creating sndstat...done.
Creating music...done.
Creating dmmidi?...done.
Creating dmfm?...done.
Creating amixer?...done.
Creating adsp?...done.
Creating amidi?...done.
Creating admmidi?...done.
rm: impossible de supprimer «/dev/snd»: est un dossier
rm: impossible de supprimer «/dev/snd/by-path»: est un dossier
rmdir: échec de suppression de «/dev/snd»: Le dossier n'est pas vide
Creating snd/control?...done.
Creating snd/seq...done.
Creating snd/timer...done.
Creating snd/hw??...done.
Creating snd/midi??...done.
Creating snd/pcm??p...done.
Creating snd/pcm??c...done.
Creating aload?...done.
Creating aloadSEQ...done.
Remove Folder.....
./install: 47: ./install: alsaconf: not found
J'ai été voir ici http://forum.ubuntu-fr.org/viewtopic.php?id=63177
Ca ne fonctionne toujours pas.

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Son micro très bas

25 mai 2014, 20:56

Si je comprend bien tu as installé les sources complètes de ta version de noyau comme indiqué dans le lien que tu donnes et cela ne marche pas.
Dura Lex sed Lex

benhux
Messages : 5
Enregistré le : 22 mai 2014, 21:30
Contact : Envoyer un message privé

Re: Son micro très bas

26 mai 2014, 10:38

Oui, c'est ça.

J'ai fait un

Code : Tout sélectionner

uname -r
Pour avoir la version.

Puis

Code : Tout sélectionner

aptitude search linux
Ensuite

Code : Tout sélectionner

sudo aptitude install  linux-headers-numerodemaversion
avec le numéro de ma version bien entendu , l'installation se fait sans problème.

Puis j'ai refait un

Code : Tout sélectionner

./install
Comme le résultat n'était pas probant, j'ai testé l'installation manuelle expliquée dans le fichier 'Readme.txt'.

Le résultat ne change pas. Même message d'erreur.

Retourner vers « Xubuntu »