crabenfolie19
Messages : 5
Enregistré le : 24 févr. 2016, 10:53
Contact : Envoyer un message privé

problème avec grub

24 févr. 2016, 18:40

Bonjour à tous, :)
je suis un débutant sous xubuntu et je l'ai installé sur mon ordinateur en dual boot. Au démarrage grub se lance et je dois sélectionner l'OS que je veux lancer.
Par défaut l'OS qui se lancait était xubuntu et je préférais avoir windows 7. J'ai appris pour cela qu'il fallait modifier la valeur de GRUB_DEFAULT dans etc/default/grub . Seulement pour ouvrir le fichier en mode administrateur j'ai tapé la commande sudo rm grub et j'ai supprimé le fichier ... Du coup en cherchant sur internet j'ai trouvé une image de fichier grub et j'ai recopié le paramètre à modifier et j'ai tout remis en place...et ça a marché j'ai changé l'os pas défaut.
Seulement mon fichier n'est pas le même qu'avant et ça me perturbe. Le lendemain mon ordinateur fait des mises à jour quand soudain un mesage s'affiche et me propose d'installer un paquet grub par défaut ou quelque chose comme ça...L'installation se termine et je regarde dans le répertoire un fichier grub.ucf-dist est apparu et ressemble à celui que j'ai supprimé le jour d'avant. L'ordre de démarrage n'a pas changé pour autant donc l'installation de ce fichier n'a visiblement pas d'effet.

J'ai 2 questions :
_La première : qu'est ce qui s'est passé ? Pourquoi cette extension grub.ucf-dist alors qu'il reste typé comme un document texte brut?
_La deuxième :est-ce que je devrais renommer le fichier grub.ucf-dist en grub, mofifier le paramètre GRUB_DEFAULT, et supprimer le fichier grub que j'ai créé ?(et tout est pour le mieux)

En vous remerciant par avance de votre aide.

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: problème avec grub

25 févr. 2016, 01:12

Hello crabenfolie19, si grub fonctionne comme tu le désires ne bouge à rien. De la documentation ICI, LA, INTÉRESSANT, CECI, UTILE.
Dura Lex sed Lex

crabenfolie19
Messages : 5
Enregistré le : 24 févr. 2016, 10:53
Contact : Envoyer un message privé

Re: problème avec grub

05 mars 2016, 20:53

Ok merci pour la documentation ;)

Retourner vers « Xubuntu »