Paxman
Messages : 3
Enregistré le : 27 avr. 2020, 09:18
Contact : Envoyer un message privé

[Résolu] Le système de paquet est cassé

27 avr. 2020, 13:14

Bonjour à vous,

Je suis en Xubuntu et je n'arrive pas à mettre à jour mon système avec le message suivant :

Vérifiez si vous utilisez des dépôts de tierces parties. Si c'est le cas, désactivez-les car ils sont une source habituelle de problèmes.
De plus, exécutez la commande suivante dans un terminal : sudo apt-get install -f
Transaction failed: Le système de paquets est cassé
Les paquets suivants ont des dépendances non satisfaites :

waylandpp-dev: Depends: libwayland-client++ mais il n'est pas installé
Depends: libwayland-client-extra++ mais il n'est pas installé
Depends: libwayland-cursor++ mais il n'est pas installé
Depends: libwayland-egl++ mais il n'est pas installé
Depends: wayland-scanner++ (= 0.2.5-2~disco) mais la version 0.2.5-2~disco est installée

J'ai testé le sudo apt-get install -f proposé mais ça ne marche pas également :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
libnfs11 libwayland-client++0 libwayland-client-extra++0
libwayland-cursor++0 libwayland-egl++0 python-pycryptodome python-simplejson
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
libwayland-client++ libwayland-client-extra++ libwayland-cursor++
libwayland-egl++
Les NOUVEAUX paquets suivants seront installés :
libwayland-client++ libwayland-client-extra++ libwayland-cursor++
libwayland-egl++
0 mis à jour, 4 nouvellement installés, 0 à enlever et 257 non mis à jour.
Il est nécessaire de prendre 0 o/107 ko dans les archives.
Après cette opération, 561 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 223233 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libwayland-client++_0.2.5-2~disco_amd64.deb ...
Dépaquetage de libwayland-client++:amd64 (0.2.5-2~disco) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libwayland-client++_0.2.5-2~disco_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libwayland-client++.so.0.2.5 », qui appartient aussi au paquet libwayland-client++0:amd64 0.2.5-1
Préparation du dépaquetage de .../libwayland-client-extra++_0.2.5-2~disco_amd64.deb ...
Dépaquetage de libwayland-client-extra++:amd64 (0.2.5-2~disco) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libwayland-client-extra++_0.2.5-2~disco_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libwayland-client-extra++.so.0.2.5 », qui appartient aussi au paquet libwayland-client-extra++0:amd64 0.2.5-1
Préparation du dépaquetage de .../libwayland-cursor++_0.2.5-2~disco_amd64.deb ...
Dépaquetage de libwayland-cursor++:amd64 (0.2.5-2~disco) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libwayland-cursor++_0.2.5-2~disco_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libwayland-cursor++.so.0.2.5 », qui appartient aussi au paquet libwayland-cursor++0:amd64 0.2.5-1
Préparation du dépaquetage de .../libwayland-egl++_0.2.5-2~disco_amd64.deb ...
Dépaquetage de libwayland-egl++:amd64 (0.2.5-2~disco) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libwayland-egl++_0.2.5-2~disco_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libwayland-egl++.so.0.2.5 », qui appartient aussi au paquet libwayland-egl++0:amd64 0.2.5-1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libwayland-client++_0.2.5-2~disco_amd64.deb
/var/cache/apt/archives/libwayland-client-extra++_0.2.5-2~disco_amd64.deb
/var/cache/apt/archives/libwayland-cursor++_0.2.5-2~disco_amd64.deb
/var/cache/apt/archives/libwayland-egl++_0.2.5-2~disco_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Auriez-vous une suggestion ?

En vous remerciant.
Modifié en dernier par Paxman le 14 mai 2020, 10:57, modifié 1 fois.

Serpolet
Messages : 933
Enregistré le : 02 févr. 2019, 19:19

Re: Le système de paquet est cassé

29 avr. 2020, 20:59

hello

as-tu synaptic d'installé ?

https://doc.ubuntu-fr.org/synaptic

https://debian-facile.org/doc:systeme:apt:synaptic

il y a une option dans un menu à gauche pour réparer les paquets cassés, c'est ce que j'utilise et ça fonctionne bien

Paxman
Messages : 3
Enregistré le : 27 avr. 2020, 09:18
Contact : Envoyer un message privé

Re: Le système de paquet est cassé

02 mai 2020, 07:34

Merci pour ton retour.

Malheureusement j'ai un message d'erreur quand je tente de l'installer.
Ca m'indique qu'il faut pour cela remplacer libwayland-client++.so.0.2.5 qui est justement le paquet qui me pose problème :|

Serpolet
Messages : 933
Enregistré le : 02 févr. 2019, 19:19

Re: Le système de paquet est cassé

02 mai 2020, 14:11

[RESOLU] Library libsasl2.so.3 demandée par APT mais non dispo U16.04

https://forum.ubuntu-fr.org/viewtopic.php?id=2033715

Paxman
Messages : 3
Enregistré le : 27 avr. 2020, 09:18
Contact : Envoyer un message privé

Re: Le système de paquet est cassé

02 mai 2020, 16:54

Merci encore.

Pas sûr que ça réponde à mon problème en l'état mais je vais tenter ma chance sur ce forum.
Je viendrai clôturer ici avec le solution si ça fonctionne ^^

Serpolet
Messages : 933
Enregistré le : 02 févr. 2019, 19:19

Re: Le système de paquet est cassé

13 mai 2020, 13:17

c'est l'idée, peut-être que la réponse de l'autre forum sera à adapter à ta problématique

Retourner vers « Xubuntu »