Ernie95
Messages : 5
Enregistré le : 10 avr. 2020, 16:07
Contact : Envoyer un message privé

[Resolu] Autofs et Xubuntu 18.04

05 mai 2020, 15:43

Bonjour,

Depuis quelques semaines mon autofs ne fonctionne plus sous Xubuntu 18.04.

Mon fichier auto.master contient les lignes actives suivantes:

Code : Tout sélectionner

/mnt/pi /etc/autopi.nfs --ghost,--timeout=30
Et autopi.nfs contient:

Code : Tout sélectionner

seagate -fstype=nfs,rw,rsize=8192,wsize=8192 192.168.150.3:/media/seagate
En mode debug, j'ai les informations suivantes:

Code : Tout sélectionner

Starting automounter version 5.1.2, master map /etc/auto.master

using kernel protocol version 5.05

lookup_nss_read_master: reading master file /etc/auto.master

do_init: parse(sun): init gathered global options: (null)

lookup_read_master: lookup(file): read entry /mnt/pi

master_do_mount: mounting /mnt/pi

automount_path_to_fifo: fifo name /var/run/autofs.fifo-mnt-pi

lookup_nss_read_map: reading map file /etc/autopi.nfs

do_init: parse(sun): init gathered global options: (null)

mounted indirect on /mnt/pi with timeout 30, freq 8 seconds

st_ready: st_ready(): state = 0 path /mnt/pi

ghosting enabled

expire_proc: exp_proc = 139841500448512 path /mnt/pi
Que faire ?

Merci par avance

PS : c'est autofs qui est à l'origine d'un bureau gris sans icone. Si je commente les lignes de auto.master, démarrage sans soucis.
Potentiellement une mise à jour de Xubuntu 18.04
Modifié en dernier par Ernie95 le 05 mai 2020, 18:22, modifié 1 fois.

pingux
Messages : 2489
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Autofs et Xubuntu 18.04

05 mai 2020, 17:35

Un peu de lecture ICI devrait peut être t'être utile
Dura Lex sed Lex

Ernie95
Messages : 5
Enregistré le : 10 avr. 2020, 16:07
Contact : Envoyer un message privé

Re: Autofs et Xubuntu 18.04

05 mai 2020, 18:06

Merci. Cette page web est ma page source pour mettre en place autofs. Mais je sèche.
J'ai avancé un peu.
Un montage manuel me dit:

Code : Tout sélectionner

sudo mount -v -t nfs -o rw 192.168.150.3:/media/seagate /mnt/pi/seagate/
mount.nfs: timeout set for Tue May  5 18:02:56 2020
mount.nfs: trying text-based options 'vers=4.2,addr=192.168.150.3,clientaddr=192.168.150.59'
mount.nfs: mount(2): Stale file handle
J'ai vérifier sur le serveur que nfs-common est bien activé et c'est bien le cas.
Le client voit bien le serveur:

Code : Tout sélectionner

showmount -e 192.168.150.3
Export list for 192.168.150.3:
/media/seagate *
Je continue mon enquête, merci par avance si vous avez des idées

Ernie95
Messages : 5
Enregistré le : 10 avr. 2020, 16:07
Contact : Envoyer un message privé

Re: Autofs et Xubuntu 18.04

05 mai 2020, 18:21

Résolu ainsi (https://ubuntuplace.info/questions/3582 ... not-umount)

"Un mount -t nfs échoue avec Stale file handle si le serveur a des entrées d'exportation périmées pour ce client.

Exemple de scénario: cela peut se produire lorsque le serveur redémarre sans que le client démonte d'abord les volumes nfs. Lorsque le serveur est de retour et que le client tente alors de monter et de monter le volume nfs auquel le serveur peut répondre:

mount.nfs: Stale file handle

Vous pouvez vérifier cela en consultant /proc/fs/nfs/exports ou /proc/fs/nfsd/exports . S'il existe une entrée pour le client, il peut s'agir d'une entrée obsolète.

Vous pouvez résoudre ce problème en désexportant explicitement et en réexportant les exportations correspondantes sur le serveur. Par exemple, pour cela avec toutes les exportations:

# exportfs -ua
# cat /proc/fs/nfs/exports
# exportfs -a

Après cela, le mount -t nfs ... du client doit réussir. "

pingux
Messages : 2489
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: [Resolu] Autofs et Xubuntu 18.04

06 mai 2020, 11:07

Merci pour le retour d'expérience. ;)
Dura Lex sed Lex

Retourner vers « Xubuntu »