adri560
Messages : 3
Enregistré le : 14 avr. 2013, 11:51
Contact : Envoyer un message privé

Grub ne s'affiche pas au démarrage

14 avr. 2013, 12:00

Bonjour,

J'ai un petit soucis, j'ai installé Xubuntu 12.04.2 il y a quelques jours en dual boot avec Windows XP.
Seulement au démarrage de l'ordinateur, le grub ne s'affiche pas et l'ordi démarre directement sur Xubuntu.

Mais j'ai l'impression que le grub fonctionne en "arrière plan" car pendant qu'il charge j'ai le message suivant qui s'affiche à l'écran.

"Input signal of range
change settings 1280x1024 60Hz"

Comme si le problème venait de ma carte graphique donc j'ai voulu enlever l'interface graphique du grub mais quand je tape la commande sudo gedit/etc/default/grub dans le terminal, ça me mets command not found alors que sur Ubuntu il me semble que ça marche.

Donc avez-vous une idée de quelle commande il s'agit pour enlever l'interface graphique du grub ?

Merci de votre aide.

olivia
Messages : 140
Enregistré le : 09 déc. 2011, 10:23
Localisation : Versailles - France
Contact : Envoyer un message privé Site Internet

Re: Grub ne s'affiche pas au démarrage

14 avr. 2013, 12:59

Salut Adri
Pour voir grub au démarrage essaies de maintenir la touche MAJ enfoncée pendant le démarrage.
Bise, Olivia.

adri560
Messages : 3
Enregistré le : 14 avr. 2013, 11:51
Contact : Envoyer un message privé

Re: Grub ne s'affiche pas au démarrage

14 avr. 2013, 14:00

Bonjour Olivia,

Cela ne change rien.
Le problème est dans le fichier grub il faut enlever le # devant GRUB_TERMINAL=console

Mais je ne sais pas comment y accéder depuis Xubuntu. Je l'avais fais avant avec Ubuntu mais là je ne sais pas.

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Grub ne s'affiche pas au démarrage

14 avr. 2013, 22:52

Mais je ne sais pas comment y accéder depuis Xubuntu. Je l'avais fais avant avec Ubuntu mais là je ne sais pas
Hello, c'est la même manip avec Xubuntu, avec l'éditeur de texte et avec les droits d'administration il suffit d'ouvrir /etc/default/grub ;)
Et ne pas oublier après modification de ce fichier de faire dans une console sudo update-grub
Dura Lex sed Lex

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Grub ne s'affiche pas au démarrage

16 avr. 2013, 18:44

Comme si le problème venait de ma carte graphique donc j'ai voulu enlever l'interface graphique du grub mais quand je tape la commande sudo gedit/etc/default/grub dans le terminal, ça me mets command not found alors que sur Ubuntu il me semble que ça marche.
Hum, j'avais pas vu :oops: . Gedit n'est pas installé par défaut sur Xubuntu, l'éditeur de texte est Leafpad ou alors tu installes Gedit. Le problème ne vient pas de ta carte graphique mais de la résolution d'affichage. Quand tu auras édité le fichier essaie en enlevant le "#" devant la ligne GRUB_GFXMODE=640x480
Dura Lex sed Lex

adri560
Messages : 3
Enregistré le : 14 avr. 2013, 11:51
Contact : Envoyer un message privé

Re: Grub ne s'affiche pas au démarrage

17 avr. 2013, 13:49

Bonjour,

Je ne suis pas chez moi en ce moment c'est pourquoi je ne vous ai pas répondu tout de suite.
C'est un vieux PC que j'ai récupérer pour ma mère et comme il lui fallait pour lundi du coup j'ai formaté la partition de xubuntu et seulement gardé Windows XP. Quand je récupérerai la machine et je vais refaire une installation en dual boot.

Je vais suivre vos conseils et je vous retiens au courant

Merci.

chze
Messages : 3
Enregistré le : 20 mai 2013, 12:25
Contact : Envoyer un message privé

Re: Grub ne s'affiche pas au démarrage

20 mai 2013, 12:34

bonjour tout le monde,
Comme Xubuntu marche bien sur mon mon AspireOne 110, je viens d'installer Xubuntu sur un de mes PC et au demarrage je n'ai pas l'invitation pour choisir entre XP et xubuntu.
Donc, je n'arrive pas à demarrer xubuntu et de ce fait, je ne sais pas acceder à sa consolepour voir a modifier le grub.

Quelqu'un à une idée ?

k-bag
Messages : 62
Enregistré le : 04 mai 2012, 09:49
Contact : Envoyer un message privé Site Internet

Re: Grub ne s'affiche pas au démarrage

20 mai 2013, 17:17

Bonjour :)

@ adri560
Dans ton /etc/default/grub la ligne GRUB_HIDDEN_TIMEOUT doit être commentée (Avec un # au début).

@chze
Tu peux démarrer de n'importe quel live-cd/usb... d'une distribution GNU/Linux pour avoir accès à tes fichiers de configuration et pouvoir les modifier.
Xubuntu 12 (RÀS) -- Win$ 7 (Le "pas mal" en fin compte)
" L'intelligence, c'est pas sorcier, il suffit de penser à une connerie et de dire l'inverse. "

chze
Messages : 3
Enregistré le : 20 mai 2013, 12:25
Contact : Envoyer un message privé

Re: Grub ne s'affiche pas au démarrage

20 mai 2013, 20:36

Merci !
Pour sauver la modif, il faut taper su ? puis le mot de passe du cd live ?

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: Grub ne s'affiche pas au démarrage

21 mai 2013, 23:57

@chze
Tu peux démarrer de n'importe quel live-cd/usb... d'une distribution GNU/Linux pour avoir accès à tes fichiers de configuration et pouvoir les modifier
Je crains que cela ne marche pas, car pour que la modif soit prise en compte il faut impérativement faire un sudo update-grub ce qui n'est possible que quand on est dans une session.
Une autre possibilité est d'utiliser Super Grub 2 que tu pourras télécharger ICI. Il faut ensuite graver l'image .iso sur un cd et démarrer le pc avec ce cd. Une fois le système lancé il faut choisir "Detect any operating system" ce qui peut prendre un peu de temps. Lorsque les systèmes d'exploitations auront été détectés tu choisis "Ubuntu" ce qui aura pour effet de démarrer ta session Xubuntu, tu lances un terminal, et tu tapes sudo grub-install /dev/sda ensuite la commande suivante sudo update-grub. Tu redémarres le pc en ayant pris soins de retirer le cd avant le redémarrage et la tu dois avoir grub qui te propose de choisir ton système d'exploitation. J'ai testé personnellement cette procédure avec succès.
Dura Lex sed Lex

chze
Messages : 3
Enregistré le : 20 mai 2013, 12:25
Contact : Envoyer un message privé

Re: Grub ne s'affiche pas au démarrage

03 juin 2013, 13:14

Merci pingux !

Retourner vers « Xubuntu »