Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

comment installer Qtstalker sur X 14

05 mars 2015, 20:17

Salut,
Je souhaite installé le logiciel Qtstalker, mais je ne le trouve pas dans synaptique et
avec un sudo apt-get install... ça ne fonctionne pas. Quelles astuces faut-il utiliser ?
SVP Merci d'avance.

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

05 mars 2015, 23:16

Tu peux télécharger le .deb ICI.
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

06 mars 2015, 00:18

Merci pour ta réponse.
En utilisant la logithèque, j'ai un mess. d'erreur qui m'indique que le libdb4.2 ne peut être satisfait. :?

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

06 mars 2015, 20:29

Tu es sûr pour " libdb4.2".
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

07 mars 2015, 17:54

Avant l'installation la Logithèque affiche que cette dépendance ne peut être satisfaite.
A la suite en faisant l'install par le terminal, même message ce qui à l'air de tout bloquer.
C'est compliqué :cry:

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

08 mars 2015, 05:42

Bon, il va falloir modifier le fichier sources.list. Pour cela dans un terminal :
sudo mousepad /etc/apt/sources.list
Si tu es sous 14.04 tu ajoutes ces deux lignes :
deb http://fr.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty universe

Si tu es sous 14.10 tu ajoutes ces deux lignes :
deb http://fr.archive.ubuntu.com/ubuntu/ utopic universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ utopic universe

Tu sauvegardes le fichier, et dans le terminal tu lances :

Code : Tout sélectionner

sudo apt-get update
Tu refais une installation de Qtstalker avec la logithèque
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

08 mars 2015, 17:29

Après avoir entré la commande : sudo mousepad /etc/apt/sources.list
J'ai un mess. qui me dit que je risque d'endommager mon système, mais à la suite lorsque j'ajoute
la 1ére des 2 lignes dans le terminal " http://fr.archive.ubuntu.com/ubuntu/ " rien ne se passe.
Il y a une manip. que je n'ai pas dû faire correctement, en tout cas je ne sais pas. HELP ! PLEASE :oops:

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

08 mars 2015, 18:09

J'ai un mess. qui me dit que je risque d'endommager mon système
C'est normal, avertissement de sécurité. Il suffit d'ajouter les deux lignes à la fin du fichier, d'enregistrer le fichier et ensuite de faire sudo apt-get update dans un terminal et de tenter une nouvelle installation.
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

08 mars 2015, 23:44

J'ai maintenant dans le terminal 2 mess :

E: Ligne 57 mal formée dans la liste de sources /etc/apt/sources.list (distribution)
E: La liste des sources ne peut être lue.

Avec la Logithèque qui crash à chaque démarrage.

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

10 mars 2015, 04:06

En plus du pb de logithèque, je ne peux plus faire de mise à jour... Synaptic crach aussi.

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

10 mars 2015, 07:40

Les lignes que tu dois ajouter si tu es sous 14.04

Code : Tout sélectionner

deb http://fr.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty universe
Les lignes que tu dois ajouter si tu es sous 14.10

Code : Tout sélectionner

deb http://fr.archive.ubuntu.com/ubuntu/ utopic universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ utopic universe
Tu peux faire des copier coller afin d'éviter les erreurs de syntaxe, ces ligne sont à ajouter à la fin du fichier "sources.list"
Pour résoudre ton problème de logithèque, dans un terminal :

Code : Tout sélectionner

sudo apt-get purge software-center
sudo apt-get install software-center
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

10 mars 2015, 11:12

J'utilise toujours le copier coller, bien pratique.
Comme il s'affiche toujours erreur ligne 57. Est ce qu'il n'y a pas un truc par là ?
Voici la fin du doc :

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main
deb http://fr.archive.ubuntu.com/ubuntu/
deb-src http://fr.archive.ubuntu.com/ubuntu/
deb http://fr.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty universe

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

10 mars 2015, 12:45

Édite ton fichier sources.list tu sélectionnes tout et tu le colles dans ton prochain post.
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

10 mars 2015, 14:32

Voici :

# deb cdrom:[Xubuntu 12.04.3 LTS _Precise Pangolin_ - Release i386 (20130820)]/ precise main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty universe
deb http://dm.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://dm.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main
deb http://fr.archive.ubuntu.com/ubuntu/
deb-src http://fr.archive.ubuntu.com/ubuntu/
deb http://fr.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty universe

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

10 mars 2015, 14:38

Je viens de voir qu'au début, il est indiqué XU... 12.04 alors que je suis dans le 14.04.
C'est bien compliqué :shock:

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

10 mars 2015, 19:33

Tu commentes les lignes 57 et 58 comme ci-dessous et tu enregistres le fichier.

Code : Tout sélectionner

# deb cdrom:[Xubuntu 12.04.3 LTS _Precise Pangolin_ - Release i386 (20130820)]/ precise main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty universe
deb http://dm.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://dm.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://dm.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://dm.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main
# deb http://fr.archive.ubuntu.com/ubuntu/
# deb-src http://fr.archive.ubuntu.com/ubuntu/
deb http://fr.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty universe
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

11 mars 2015, 00:06

Merci Pingux, les choses retournent au calme. Par contre en tentant d'installer à nouveau le logiciel, j'obtiens toujours le même message ; la dépendance Libdb4.2 ne peut être satisfaite. Retour à 0 8-)

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

11 mars 2015, 00:43

Pas de traces de lidb4.8, mais il existe une version 5.1 essaie de l'installer via un terminal :

Code : Tout sélectionner

sudo apt-get install lidb5.1
Et ensuite retente l'installation de ton logiciel.
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

11 mars 2015, 15:05

Je n'ai que trouver que cette ligne qui fonctionne, je ne sais pas si c'est OK.

sudo apt-get install libdb5.1-dev libdb5.1++-dev

...en installant le logiciel, le terminal affiche :
fifor@fifor-dynabook-CX-45A:~$ sudo apt-get install qtstalker
[sudo] password for fifor:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet qtstalker n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

11 mars 2015, 15:17

Essaie à partir du fichier .deb que tu as dû télécharger ICI.
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

11 mars 2015, 15:22

Je suis retombé sur le même soucis de dépendance non satisfaite lidb... :roll:

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

11 mars 2015, 15:32

(Etant sur 14.1)
J'y pense peut être que le mieux serais que je puisse réutiliser la version 12.04, le soucis est qu'au démarrage la vérification du disc dur n'en finit pas. Dois je effacer cette version pour la réinstaller afin de récupérer ce logiciel ???

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

11 mars 2015, 18:45

Dois je effacer cette version pour la réinstaller afin de récupérer ce logiciel ???
Je crois qu'il vaut mieux.
Dura Lex sed Lex

pingux
Messages : 2508
Enregistré le : 28 déc. 2011, 17:19
Localisation : Belgique
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

11 mars 2015, 19:02

Je viens de trouver libdb4.4-dev, c'est ICI, tu choisis selon ton architecture, à savoir amd64 si tu est en 64 bits ou i386 si tu es en 32 bits. Il s'agit d'un paquet .deb facile à installer.
Dura Lex sed Lex

Fidor
Messages : 79
Enregistré le : 07 nov. 2013, 12:38
Contact : Envoyer un message privé

Re: comment installer Qtstalker sur X 14

17 mars 2015, 14:20

Toutes les manips de ces derniers jours ne m'ont pas apportées d'issus favorables donc, je suis retourné à la version Xub 12.04 où ce logiciel fonctionne très bien.

Merci tout de même pour le coup, c'est toujours un apprentissage.
A plus ;)

Retourner vers « Xubuntu »